티스토리 뷰

Linux

Headers and client library minor version mismatch

초보의 CHOMAN 2019.10.22 08:38

centos6.10 에서 php 5.3.3 과 mysql connect시 발생하는 문제점

헤더와 클라이언트 버전이 다르다는 소리인데

php -i | grep 'Client API'
Client API version => 5.3.12-MariaDB
Client API library version => 5.3.12-MariaDB
Client API header version => 5.1.73
Client API version => 5.3.12-MariaDB

Client API 의 라이브러리 버전과 헤더 버전이 달라서 발생하는 문제

기존 centos6.4 에서 php 5.2 이용시에는

php-mysqlnd-5.3.27-3.el6.x86_64 

5.3 버전에는 mysqlnd 를 찾을수 없음

php-mysql-5.3.3-49.el6.x86_64

5.3.3 버전의 mysqlnd 를 구할수 없는 상황

5.2로 다운그레이드 하거나 5.4 버전으로 업그레이드 해야 하는 상황인듯 함

댓글
댓글쓰기 폼